Blank Screen


Forum » General Forums » General discussion

By ollyolly on 05/03/21 at 10:15am

I was just wondering if anyone else was having the same problem as me. When I select the GPS mapping link a new page opens as normal. Top left is the box where you can say where you want to go to. The rest of the screen is blank.


By TallPaul on 05/03/21 at 10:26am

Looks fine from here. It sounds like the JavaScript isn't running for some reason. You haven't accidentally turned it off have you?

You can check if it's running using the tool here for example.

If it is running then are you using an ad blocker? If you are then try disabling that for our site and see if that helps.


By ollyolly on 06/03/21 at 8:16am

Thanks for your reply Paul. Java script reports as running using the link you supplied, thank you. I've not installed any kind of ad blocker. All other pages on WalkLakes appear to be displaying correctly.


By TallPaul on 06/03/21 at 9:34am

Curious. OK, it looks like you're using Microsoft Edge on Windows 10 so open the "Developer Tools" by holding down Ctrl and Shift and pressing the "I" key. A new window should open in your browser. Select "Console" at the top and you should get something that looks vaguely like this:

Take a screen shot of that area (it's the text with the pink background I want to see) and then post it here.


By ollyolly on 07/03/21 at 8:12am (last edited 07/03/21 at 8:13am)
Hi Paul, It's very good of you spending time trying to resolve my problem, thank you. Yes I'm using Windows 10 and Edge. Screen shot attached showing all the text. Not as much text as your example, and it's all gobbly goo to me.

Cheers,

Andrew


By ollyolly on 07/03/21 at 8:21am

Hi Paul, Looking at the screenshot I noticed there was an 'issues' option. So I went back into GPS mapping to view the issues and the amount of pink text had increased. I've attached the new pink text and the issues list just in case it shows up anything different.

Cheers

Andrew



By TallPaul on 07/03/21 at 10:18am

OK, I think we're getting closer to the problem. Can you do a view source (hold down Ctrl and press 'U') and send me a screen shot of that, which will look something like this:

(It's line 22 where currentMap is defined that interests me most at the moment but give me as much as you can from line 1 downwards.)


By ollyolly on 08/03/21 at 10:11am

Hi Paul,

Image of the source code attached. Hope it makes sense to you as it doesn't to me.

Cheers,

Andrew


By TallPaul on 08/03/21 at 4:45pm

I see a green key and a green shield next to the address bar. What are those please?


By ollyolly on 09/03/21 at 5:24pm (last edited 09/03/21 at 5:31pm)

Hi Paul,

Both the key and shield are part of my Kaspersky Total Security. It's been installed for over 18 months. I've just noticed that if I select the three bar menu at the top left of the screen nothing happens.


By TallPaul on 10/03/21 at 11:23am

It wouldn't. That's driven by JavaScript and the program has given but by that point owing to earlier errors.

As for Kaspersky Total Security you'll remember that much earlier I said:

are you using an ad blocker? If you are then try disabling that for our site and see if that helps.

... and among other things Kaspersky Total Security is an ad blocker and I suspect this may be the problem. We've certainly had problems with "false positives" from ad blockers before anyway. So the next step it to turn that off for our web site (assuming you can do that, but you usually can on a site by site basis).


By ollyolly on 11/03/21 at 9:58am

Hi Paul,

I do apologise, I didn't realise you classed Kaspersky Total Security as an ad blocker.

I switched KTS off and WalkLakes displayed correctly as it always has done until recently. I switched KTS back on and WalkLakes failed to display correctly. So something has changed in KTS and it appears to be the culprit. All I need to do now is find a way of allowing KTS to let WalkLakes work as it should do.

Thank you for your assistance you have been most kind.

Cheers,

Andrew


By TallPaul on 11/03/21 at 11:14am

Thanks for letting me know. I have updated the FAQ to include an entry on this issue and I've specifically mentioned Kaspersky Total Security.


By SheepFarmer on 04/04/21 at 8:37am

Andrew

I also use KTS on Win10 & hadn't been having any problems but checked & it's something to do with the Anti Banner element & it effects Edge & Chrome but not Firefox, you can turn the Anti banner off, which is why I wasn't having problems or disable the extension in the effected browser, or switch to Firefox.

I'll add to save you trying & maybe help Paul that allowing or disallowing banners by clicking on the green shield in the browser has no effect as I still got problems on either setting with cookies saved. But sometimes a single refresh of the page loads the maps other times multiple refreshes are required, plus refreshing the page with the maps present can disappear them I haven't been able to discern a pattern. Adding WalkLakes as a website with allowed banners to Kaspersky seems to have no effect. The other bits of info I can add are when the maps are not there the menu list won't open but all other links still visable do work & the tips still show & clock on with each page refresh. All of this makes me think it's not just KTS thinking the maps are a banner but some complicated interaction between the maps, browser & the Anti banner element of KTS.


By ollyolly on 05/04/21 at 8:09am

Hi Sheepfarmer,

Thanks for your post most of which I understand. I have tried to get KTS to allow WalkLakes to open using the anti banner options without success and by the sound of it you have too. I think I tried opening WalkLakes in Chrome and like you got the same result. When I have a little more time I'll try Firefox, thanks for the tip. I've never used Firefox so that will be a first.

Thanks again.



WalkLakes recognises that hill walking, or walking in the mountains, is an activity with a danger of personal injury or death.
Participants in these activities should be aware of and accept these risks and be responsible for their own actions.